Ed/Glen Chamber Mobile Apps

Android App

Requires Android 2.2
(Froyo) or higher.

iPhone App

iOS 5 optimized.
(but supports iOS 3.0+)

Devices Supported:
iPhone 3G, 3GS, 4 & 4S
iPad & iPad 2
iPod Touch

BlackBerry App

Requires OS 6.0 or higher.

Devices Supported:
Bold 9650, 9700, 9780, 9788,
9790, 9900, 9930, 9981

Curve 3G 9300, 9330, 9350,
9360, 9370, 9380

Pearl 3G 9100, 9105, 9670,
9800, 9810, 9850, 9860